LinuxLatino.com

Donde hablamos de todo... Hasta de Linux | Visítanos en IRC en el canal #LinuxLatino de la red OFTC.

No estas registrado.

  • |

#1 10-19-2009 15:01:35

Edgar
Miembro
Desde: US/ny
Registrado: 10-06-2009
Mensajes: 31
Página Web

Problemas con php-zend-abi en un server centos

Hola,
Desde hace unos días atrás tengo este problema que no me deja actualizar el resto del sistema. Bueno si puedo actualizar pero tengo que ponerle flags para ignorar dependencias que creo no es lo más apropiado.

[root@InternalServer ~]# yum remove php-midgard-8.09.5-8.2
Loaded plugins: allowdowngrade, changelog, fastestmirror, kernel-module, kmod,
              : merge-conf, priorities, refresh-updatesd
Setting up Remove Process
No Match for argument: php-midgard-8.09.5-8.2
No Packages marked for removal
[root@InternalServer ~]# yum install php-midgard
Loaded plugins: allowdowngrade, changelog, fastestmirror, kernel-module, kmod,
              : merge-conf, priorities, refresh-updatesd
Loading mirror speeds from cached hostfile
 * extras: centos.mirror.nac.net
 * rpmforge: fr2.rpmfind.net
 * base: mirror.trouble-free.net
 * updates: centos.corenetworks.net
 * centosplus: www.gtlib.gatech.edu
 * addons: centos.mirror.nac.net
 * atomic: www.atomicorp.com
Excluding Packages from Plesk Server Administrator
Finished
356 packages excluded due to repository priority protections
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package php-midgard.i386 0:8.09.5-8.2 set to be updated
--> Processing Dependency: php-zend-abi = 20050922 for package: php-midgard
--> Finished Dependency Resolution
php-midgard-8.09.5-8.2.i386 from home_midgardproject_ragnaroek has depsolving pr                                        oblems
  --> Missing Dependency: php-zend-abi = 20050922 is needed by package php-midga                                        rd-8.09.5-8.2.i386 (home_midgardproject_ragnaroek)
Error: Missing Dependency: php-zend-abi = 20050922 is needed by package php-midg                                        ard-8.09.5-8.2.i386 (home_midgardproject_ragnaroek)
[root@InternalServer ~]# yum update
Loaded plugins: allowdowngrade, changelog, fastestmirror, kernel-module, kmod,
              : merge-conf, priorities, refresh-updatesd
Loading mirror speeds from cached hostfile
 * extras: centos.mirror.nac.net
 * rpmforge: fr2.rpmfind.net
 * base: pubmirrors.reflected.net
 * updates: updates.interworx.info
 * centosplus: www.gtlib.gatech.edu
 * addons: ftp.lug.udel.edu
 * atomic: www.atomicorp.com
Excluding Packages from Plesk Server Administrator
Finished
356 packages excluded due to repository priority protections
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package php.i386 0:5.2.11-2.el5.art set to be updated
---> Package php-common.i386 0:5.2.11-2.el5.art set to be updated
---> Package php-ldap.i386 0:5.2.11-2.el5.art set to be updated
---> Package kernel.i686 0:2.6.18-164.2.1.el5.plus set to be installed
---> Package kernel-headers.i386 0:2.6.18-164.2.1.el5.plus set to be updated
---> Package php-devel.i386 0:5.2.11-2.el5.art set to be updated
---> Package php-cli.i386 0:5.2.11-2.el5.art set to be updated
---> Package php-gd.i386 0:5.2.11-2.el5.art set to be updated
---> Package php-pdo.i386 0:5.2.11-2.el5.art set to be updated
---> Package php-mysql.i386 0:5.2.11-2.el5.art set to be updated
---> Package php-midgard.i386 0:8.09.5-8.2 set to be updated
--> Processing Dependency: php-zend-abi = 20050922 for package: php-midgard
--> Finished Dependency Resolution
php-midgard-8.09.5-8.2.i386 from home_midgardproject_ragnaroek has depsolving problems
  --> Missing Dependency: php-zend-abi = 20050922 is needed by package php-midgard-8.09.5-8.2.i386 (home_midgardproject_ragnaroek)
Excluding to be erased: kernel-2.6.18-128.1.6.el5.i686
--> Running transaction check
---> Package kernel.i686 0:2.6.18-128.1.6.el5 set to be erased
---> Package php-midgard.i386 0:8.09.5-8.2 set to be updated
--> Processing Dependency: php-zend-abi = 20050922 for package: php-midgard
--> Finished Dependency Resolution
php-midgard-8.09.5-8.2.i386 from home_midgardproject_ragnaroek has depsolving problems
  --> Missing Dependency: php-zend-abi = 20050922 is needed by package php-midgard-8.09.5-8.2.i386 (home_midgardproject_ragnaroek)
Error: Missing Dependency: php-zend-abi = 20050922 is needed by package php-midgard-8.09.5-8.2.i386 (home_midgardproject_ragnaroek)
[root@InternalServer ~]#

A visto alguien algo parecido?


Imaginación es más importante que conocimiento.
- Albert Einstein

Desconectado

#2 10-19-2009 15:34:00

Edgar
Miembro
Desde: US/ny
Registrado: 10-06-2009
Mensajes: 31
Página Web

Re: Problemas con php-zend-abi en un server centos

Ya encontre la solucion, creo que el problema empeso cuando queria provar el midgard que es un framework, la cosa es que cuando usas el midgard, tambien tienes que tenet ep EPEL de fedora en tus repositiorios, asi que para arreglar el problema puse:

rpm -Uvh http://download.fedora.redhat.com/pub/e … noarch.rpm
yum install php-zend-abi

Y ya, si tengo otra pregunta por aqui vengo a ver si me la respondo yo mismo  lol


Imaginación es más importante que conocimiento.
- Albert Einstein

Desconectado

#3 10-20-2009 09:43:45

E0x
Administrator
Registrado: 10-06-2009
Mensajes: 17

Re: Problemas con php-zend-abi en un server centos

hehe , es que no diste tiempo a ver el post y contestar , contestaste en 30 minutos

Desconectado

Pie de página

Powered by FluxBB